command-line forwarding doesn't seem to work in 2.1

Topics: Problems
Sep 24, 2011 at 1:01 AM

"C:\Program Files (x86)\Finestra\VirtualDesktops.exe" 2:cmd.exe

Under v1.2, the line above would run cmd.exe and make it appear on Window 2

But under 2.1, all applications appear in Window 1, regardless of how I vary the integer in front of ":cmd.exe"

Sep 24, 2011 at 6:41 PM

Haha, you found the one feature I retracted from the 2.0 release and forgot to put back in. I plan to put it back in the next release. The reason I temporarily removed it in the first place was because it resulted in an interdependency across two components that I separated into plugins. For now, I would suggest using the "rules" feature in the options window. Sorry for any confusion.

Sep 25, 2011 at 2:57 PM
No worries -- I appreciate the work you invest into Finestra -- this
application saves me a bunch of time.

Of the ~60 'apps' I open on boot (distributed across four Desktops),
most of them are ssh sessions to various hosts. So I don't think
'Program Rules' will help me here (plse correct me if I'm mistaken!) ...
i.e. the executable name in the process table is the same (rwin.exe).

But that's alright; v1.2 works well enough for me; I'll hang there for now.

On a possibly related note, do you understand what happens with
applications like Firefox or Thunderbird? Once I have launched a copy
into one Desktop, /all/ subsequent launches of that application result
in the application arriving on that original Desktop.

e.g.
"C:\Program Files (x86)\Finestra\VirtualDesktops.exe" 2:firefox.exe

results in a Firefox window opening on Desktop 2 ... but if
subsequently, I type 'firefox.exe' (or double-click on an icon pointing
to firefox.exe) in /any/ Desktop, the resulting window appears on Desktop 2.

This feels like a Program Rule to me ... but I don't see 'firefox' or
'thunderbird' in the list on the 'Program Rules' tab.

?

--sk


On 9/24/2011 10:41 AM, zhuman wrote:
> From: zhuman
>
> Haha, you found the one feature I retracted from the 2.0 release and
> forgot to put back in. I plan to put it back in the next release. The
> reason I temporarily removed it in the first place was because it
> resulted in an interdependency across two components that I separated
> into plugins. For now, I would suggest using the "rules" feature in the
> options window. Sorry for any confusion.
Oct 19, 2015 at 10:41 PM
Looks like this feature is still not implemented under 2.5.x, am I correct?